Jump to content
GregoryRasputin

Team PS3Xploit To Release Some Awesome PS3 Goodies

Recommended Posts

Today @STLcardsWS posted an awesome article on PSX-Place, talking about some great things coming to the PS3, such as the ability to downgrade via software, yes you read that right, soon you will not need any hardware flashers and all thanks to Team PS3Xploit, three developers bguerville, esc0rtd3w and W, from the above mentioned website.

 

J5Oclgg.png

 

Software downgrading was possible back in the 3.55 days, but updates and upgrades from Sony rendered them useless and we needed to use hardware devices to downgrade, which meant opening up the PS3 and also meant you had to shell out money for the device, but now all this will be a thing of the past, at least if you stay on firmware 4.81 and never upgrade again.

 

Team PS3Xploit also released IDPS Dumper v0.2 today.

 

For more information on the news above, check the source

 

Share this post


Link to post
Share on other sites
5 hours ago, BobbyBlunt said:

I hope this leads to something for 3000 and superslim models

I'm not sure if I understand the original text about the unhackables like 2504b, because they have metldr2. Will they install cfw upon release of the flasher software too?

Share this post


Link to post
Share on other sites
14 hours ago, ocam said:

I'm not sure if I understand the original text about the unhackables like 2504b, because they have metldr2. Will they install cfw upon release of the flasher software too?

No those models will still not be able to install a CFW (because they have metldr2), However this should be able to progress in a similair way that HENkaku did for the Vita.

but for models that can install CFW/Downgrade but might be on an OFW higher then 3.55, a software downgrader will let those consoles to 3.55 for CFW install easily. but SuperSlim will have to wait but the outlook is bright.

 

Bguerville gives a good rundown in the 2nd tab of the article (middle of the article you will see 3 tabs)

 

Share this post


Link to post
Share on other sites
6 hours ago, STLcardsWS said:

No those models will still not be able to install a CFW (because they have metldr2), However this should be able to progress in a similair way that HENkaku did for the Vita.

but for models that can install CFW/Downgrade but might be on an OFW higher then 3.55, a software downgrader will let those consoles to 3.55 for CFW install easily. but SuperSlim will have to wait but the outlook is bright.

 

Bguerville gives a good rundown in the 2nd tab of the article (middle of the article you will see 3 tabs)

 

Thanks for the info, it's clear now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...