Jump to content
3absiso

PS4 White Led But No Display Issue

Recommended Posts

Hi;
I got This PS4 with the following symptoms:
The PS4 Turns to White Led but no Display on the TV, sometimes no signal, sometimes Black screen in one occasion gave me screen with white dots.
I fixed PS4 with This issue, by replacing either the HDMI Port or the HDMI IC controller.
i have changed the HDMI port for this PS4 with two new ones and replaced the HDMI IC Port also two times, i also knocked one of the Filters and changed with one from an old PS3 as shown in the image. i also by mistake lifted a trace in the HDMI IC controller and fixed as shown in the same image. soldering of the IC controller looks fine and no bridges there,

There is a cap looked fishy for me and removed it but got no reading so i think it is blown (C1), i also to make sure removed another Cap (C2) and read it gave 10 microfarad, can someone tell the value of the Cap C1?

dw1iYCM.jpg

 

4NBxrl8.jpg

i am open for any ideas
thanx

Share this post


Link to post
Share on other sites

السلام عليكم و رحمة الله و بركاته اخى رائد

كيف حالك ليك وحشة و الله يا اخى؟

 

Hi @3absiso,

 

How are you my brother?

I had faced this problem before and i had did the same steps, changed HDMI port, changed HDMI chip and nothing fixed my issue until i had removed all 4 filters beside the HDMI chip and used a wires to connect it, yes you can only use a thin wire to replace it, and console working now for more than 3 months without any issue :)

I hope that it help you my brother ;)

Share this post


Link to post
Share on other sites

if it's a small one it could just be a 100nf cap, check a cap with the same color and size..

if it's a part that contributes to the hdmi controller, maybe a datasheet (if available) could help, sometimes a datasheet contains schematics for typical use..

for the rest i have no clue, not active anymore lately with consoles.. :) 

Share this post


Link to post
Share on other sites

I have exactly same problem as you...

@Abkarino do you know what are the function of these four filters... ?Because that interesting to know why are they here if we can remove them ;)

Edited by Mart1

Share this post


Link to post
Share on other sites
On 11/1/2015, 10:26:36, Abkarino said:

السلام عليكم و رحمة الله و بركاته اخى رائد

كيف حالك ليك وحشة و الله يا اخى؟

 

Hi @3absiso,

 

How are you my brother?

I had faced this problem before and i had did the same steps, changed HDMI port, changed HDMI chip and nothing fixed my issue until i had removed all 4 filters beside the HDMI chip and used a wires to connect it, yes you can only use a thin wire to replace it, and console working now for more than 3 months without any issue :)

I hope that it help you my brother ;)

 

Hi @Abkarino

سلاملت اخي محمد وانت الك وحشة. والحمد لله

Thanx Bro problem fixed by removing the Filters and bridging them by small wires as suggested by you.

and the Caps are 10uf

TylsWZe.jpg

 

W4Vkx3S.jpg

21 hours ago, Mr.Dutch said:

if it's a small one it could just be a 100nf cap, check a cap with the same color and size..

if it's a part that contributes to the hdmi controller, maybe a datasheet (if available) could help, sometimes a datasheet contains schematics for typical use..

for the rest i have no clue, not active anymore lately with consoles.. :) 

 

Hey Johan, how are you my friend. long time. the Caps are 10uf thank you Bro.

still no data sheet available i think

Share this post


Link to post
Share on other sites
23 hours ago, 3absiso said:

 

Hi @Abkarino

سلاملت اخي محمد وانت الك وحشة. والحمد لله

Thanx Bro problem fixed by removing the Filters and bridging them by small wires as suggested by you.

and the Caps are 10uf

TylsWZe.jpg

 

W4Vkx3S.jpg

 

Hey Johan, how are you my friend. long time. the Caps are 10uf thank you Bro.

still no data sheet available i think

 

الله يخليك يا اخى رائد @3absiso

 

You are welcomed every time my dear brother and i'm so glad to see your fixed your problem like what i had said :)

I faced this problem many times before and fixed it the same way without any problem after that my brother :)

 

 

Share this post


Link to post
Share on other sites

Hello, a friend of mine gave me a Playstation 4 with a similar problem. Sometimes I connect it to the TV and I see some strange dots/lines, somethimes black screen.

The strange thing is that the TV always gets a signal (1080p, 576p in safe mode) and sometimes the audio is working, I can hear the cursor moving in the main menu. However the screen stays black or with some strange dots/lines all the time. Do you think the problem on this console is the same as the one in this thread? Thank you

Edited by sguerrini97

Share this post


Link to post
Share on other sites
On 11/2/2015 at 8:37 PM, 3absiso said:

 

Hi @Abkarino

سلاملت اخي محمد وانت الك وحشة. والحمد لله

Thanx Bro problem fixed by removing the Filters and bridging them by small wires as suggested by you.

and the Caps are 10uf

TylsWZe.jpg

 

W4Vkx3S.jpg

 

Hey Johan, how are you my friend. long time. the Caps are 10uf thank you Bro.

still no data sheet available i think

did you change 10uf component too??

Share this post


Link to post
Share on other sites
On 12/17/2018 at 10:32 AM, zacarius011 said:

did you change 10uf component too??

No i think

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×